FriBID forum

FriBID är ett fritt program för e-legitimation med BankID.

You are not logged in.

#1 2010-11-28 09:37:33

odinb
Member
Registered: 2010-11-28

Fribid firefox plugin

Hej!

Kör Ubuntu Maverick 64 bit, har tidigare haft nexus installerat.

Avinstallerade nexus, och installerade fribid.

På test.bankid.com säger den "Du har rätt version av BankID säkerhetsprogram!", men när jag sedan skall legitimera mig, så vill firefox installera en plugin. Firefox misslyckas med att installera denna saknade plugin med: "No suitable plugins were found".

Under "about:plugins" ser jag:
FriBID

    File: libfribidplugin.so
    Version:
    FriBID version 0.2.1a

MIME Type     Description     Suffixes     Enabled
application/x-personal-version     Version         Yes
application/x-personal-authentication     Authentication         Yes
application/x-personal-signer2     Signer2         Yes

Vad är det jag saknar, och hur fixar jag det?

Offline

#2 2010-11-28 10:10:18

samuellb
Administratör
Registered: 2010-02-15
Website

Re: Fribid firefox plugin

Har du startat om Firefox efter installationen? Det händer att pluginen dyker upp under "about:plugins" men att den inte fungerar om tills man startar om.

Prova också att ta bort ~/.mozilla/firefox/*/pluginreg.dat och starta om Firefox igen.

Om det inte heller fungerar, kolla om det ligger några rester kvar av Nexus.-pluginen:

find / -name libplugins.so

Offline

#3 2010-11-28 18:48:08

odinb
Member
Registered: 2010-11-28

Re: Fribid firefox plugin

Hittade en rest under /usr/lib/mozilla/plugins/libplugins.so, tog bort den, och tog även bort pluginreg.dat.
Startade om firefox, men samma sak händer.

Offline

#4 2010-11-28 19:26:22

samuellb
Administratör
Registered: 2010-02-15
Website

Re: Fribid firefox plugin

Får du något i ~/.xsession-errors när du kör testet?

Offline

#5 2010-11-28 20:32:12

odinb
Member
Registered: 2010-11-28

Re: Fribid firefox plugin

Nej, inget.

Någon annan log jag kan kolla?

Tog en HTTP-trace:

http://pastebin.com/raw.php?i=cXVb5Dhd

Offline

#6 2010-11-28 20:51:46

samuellb
Administratör
Registered: 2010-02-15
Website

Re: Fribid firefox plugin

Det verkar som test.bankid.com har uppdaterats. Jag får faktiskt exakt samma fel nu när jag provade.

Jag provade även inloggning på CSN, och där fungerade det fortfarande. Fast det är väl en tidsfråga innan de "vanliga" sidorna börjar uppgraderas och man får samma problem som på testsidan.

Offline

#7 2010-11-28 22:27:27

odinb
Member
Registered: 2010-11-28

Re: Fribid firefox plugin

Jag får:
"Observera
    * Du behöver en nyare version av BankID säkerhetsprogram. Klicka på följande länk för att installera den senaste versionen:    install.bankid.com"

på CSN.

Offline

Board footer

Powered by FluxBB