FriBID forum

FriBID är ett fritt program för e-legitimation med BankID.

You are not logged in.

#1 2010-10-08 20:47:20

perssontm
Member
Registered: 2010-10-08

fribid under debian stable(lenny)

Hej,

Laddade hem debian-paketet för fribid, men det tycks kräva 2.14 av libgtk2.0-dev vilket inte ingår i lenny(endast 2.12 http://packages.debian.org/lenny/libgtk2.0-dev ). Däremot finns 2.18 i backports(http://packages.debian.org/lenny-backports/libgtk2.0-dev) se installation (http://backports.debian.org/Instructions/).

Därefter tyckte den att jag inte har libp11-1(>=0.2.3), men jag har installerat både dev och dbg,
$ aptitude search libp11
i A libp11-0                                                                                        - pkcs#11 convenience library                                                                             
i   libp11-0-dbg                                                                                    - pkcs#11 convenience library - debugging symbols                                                         
i   libp11-dev                                                                                      - pkcs#11 convenience library - development files                                                         

$ aptitude show libp11-0
Paket: libp11-0
Ny: ja
Tillstånd: installerat
Automatiskt installerade: ja
Version: 0.2.3-2
Prioritet: valfri
Sektion: libs
Underhållare: Eric Dorland <eric@debian.org>
Uppackad storlek: 57,3k
Beroende: libc6 (>= 2.6.1-1), libltdl3 (>= 1.5.2-2), libssl0.9.8 (>= 0.9.8f-1)
Konfliktar: libp11-1
Ersätter: libp11-1
Beskrivning: pkcs#11 convenience library
Libp11 is a library to simplify using smart cards via PKCS#11 modules.  It was spun of the OpenSC project but can be used with any pkcs#11 module.
Webbplats:http://www.opensc-project.org/libp11/

Det tycks som att libp11-0 ersätter libp11-0, men fribid-deb-filen verkar inte hänga med i matchen riktigt, eller också är det ngt ytterligare jag behöver göra.

Har ni några tips?

/eric

Offline

#2 2010-10-08 21:54:31

mikma
Member
Registered: 2010-09-17

Re: fribid under debian stable(lenny)

Fribid verka kräva gtk 2.18, eftersom fribid använder GtkInfoBar som introducerades i den versionen.

Det bästa är nog att bygga en ny deb fil för lenny-backports.
Och samtidigt fixa debian/control så att den automatisk detekterar libversionerna istället för att hårdkoda dessa. Då kommer den backportade fribid automatiskt använda libp11-0.

Tillägg: Om fribid deb-filen redan är kompatibel med libp11-0 utan omkompilering så skulle man kunna lägga in en symbolisk länk i /usr/lib: #ln -s libp11.so.0 /usr/lib/libp11.so.1

Last edited by mikma (2010-10-08 23:08:42)

Offline

#3 2010-10-08 23:39:23

samuellb
Administratör
Registered: 2010-02-15
Website

Re: fribid under debian stable(lenny)

Detta* orsakades mycket riktigt av att versionerna var hårdkodade i debian/control. Det var från början ett "hack" för att kunna stödja Ubuntu 8.04 även om man byggde paketen på en senare distribution. Nu så kommer det ju ändå inte att gå att köra FriBID på Ubuntu 8.04 (som precis som Debian Lenny också har GTK version 2.12). Så eftersom det bara verkar orsaka problem har jag ändrat debian/control så att den inte längre har hårdkodade beroenden.

*Uppdatering: Kanske ska förtydliga lite: Det är versionen på libp11 och att det inte går att bygga paketet på Lenny som jag syftar på här. Sen så blir det ju också problem om man har en för gammal version av GTK.

Jag har även ändrat källkoden och hemsidan så att det står att version 2.18 av GTK krävs.

Offline

#4 2010-10-09 09:48:03

perssontm
Member
Registered: 2010-10-08

Re: fribid under debian stable(lenny)

Aha, bra!

Men du har inte uppdaterat .deb-filen på hemsidan ännu va?

Jag testade i alla fall att symlänk som mikma föreslog, och installerade därefter med:
$ sudo dpkg -i --ignore-depends=libp11-1 fribid_0.2.0_i386.deb

Och direkt efter testade jag att logga in på skandiabanken med  chrome, det fungerade t.om utan omstart. Den hittade till och med mina .p12 filer per automatik. Sjukt bra!

/eric

Offline

#5 2010-10-09 14:27:44

samuellb
Administratör
Registered: 2010-02-15
Website

Re: fribid under debian stable(lenny)

Nej jag har inte uppdaterat .deb-filen.

Problemet med libp11 kan jag inte lösa i .deb filen eftersom det binära paketet för libp11 har olika namn i Debian Lenny och senare distar som Debian Unstable, Ubuntu 10.04 m.m. Däremot så ska det nu gå att skapa paket för FriBID oavsett vilken version av libp11 man har, så det bör inte vara några problem att göra en backport till Lenny.

Offline

#6 2010-10-10 14:58:13

mikma
Member
Registered: 2010-09-17

Re: fribid under debian stable(lenny)

Har du funderat på att ta bort debian från tar-filen och göra det till ett icke-native paket? Rekommendationen jag läst är att paket som enbart är ämnade för Debian (eller Ubuntu) bör vara native. Men eftersom fribid även stödjer bl.a. Arch och Fedora så bör det vara non-native.

Offline

#7 2010-10-10 15:27:00

samuellb
Administratör
Registered: 2010-02-15
Website

Re: fribid under debian stable(lenny)

Jag har inte lyckats hitta några riktlinjer för paket som görs "utanför" Debian så jag har bara antagit att man ska ha native paket om samma person/organisation gör paketet som själva programvaran (dvs som det är i Debian). Men nu när jag funderar på det igen så känns det vettigare att ha Debian-biten separat från källkoden.

Jag gör så att jag flyttar ut debian-biten och lägger den i ett eget repository (med en länk från http://wiki.fribid.se/sidor/Distributioner ).

Sen borde kanske nedladdningsknappen på startsidan ändras så att den känner av fler distar och även länka till repositories istället för direkt till paketen. Jag ska försöka lösa det på något sätt.

Offline

#8 2010-10-11 03:05:59

samuellb
Administratör
Registered: 2010-02-15
Website

Re: fribid under debian stable(lenny)

Debian-paketeringen har flyttat till GitHub nu:
http://github.com/samuellb/fribid-debian/

Om någon Debian-utvecklare skulle råka läsa detta så har jag laddat upp ett source package till mentors.debian.net, och det skulle behöva en sponsor:
http://mentors.debian.net/cgi-bin/spons … age=fribid

Offline

#9 2010-10-14 22:21:41

mikma
Member
Registered: 2010-09-17

Re: fribid under debian stable(lenny)

Får man fråga varför du inte skapade fribid-debian som en klon av git://git.fribid.se/fribid? Om man vill bygga med git-buildpackage så behövs två grenar, dels en upstream-gren och dels en debian-gren (ofta master).

Offline

#10 2010-10-14 22:44:04

samuellb
Administratör
Registered: 2010-02-15
Website

Re: fribid under debian stable(lenny)

Tanken var från början att inte ha själva koden (bara debian-filer) i repositoriet så därför gjorde jag ingen klon. Sen upptäckte jag att de flesta debian-paket hade koden inkluderad så jag lade in den sen.

Nu när jag kollar i officiella dokumentationen till git-buildpackage så ser jag att det finns riktlinjer för hur det ska vara. Jag tolkade följande mening på Debian-wikin som att man skulle vänta med git-buildpackage till andra versionen: "It is easiest to first create the first version of a package, outside of Git"

Uppdatering: Såg att det finns skrivet om just denna situation i dokumentationen för git-buildpackage.

Last edited by samuellb (2010-10-14 23:03:53)

Offline

#11 2010-10-14 23:20:18

mikma
Member
Registered: 2010-09-17

Re: fribid under debian stable(lenny)

Ja, du ska nog skapa ett nytt repository som du pushar till från den befintliga fribid repositoryn.

Offline

Board footer

Powered by FluxBB