FriBID forum

FriBID är ett fritt program för e-legitimation med BankID.

You are not logged in.

#1 2011-11-23 10:09:33

g0tr00t
Member
Registered: 2011-10-24

FriBID 1.0 i Fedora 16 x64 + Handelsbanken = Fail!

Hejsan!

Har dragit in precis alla saker jag behöver för att få kortläsaren att fungera samt få FriBID att fungera men det vill sig inte.

Trots att jag följde Wikin så stannar kortläsaren på två pluttar av tre. Vilket under Ubuntu löstes genom att lägga till pcscd i /etc/rc.local.

Sen så märker jag en väldigt skum sak och det är att FriBID går igång om jag väljer Kortläsare ansluten till datorn, och där får jag upp
att logga in med mitt BankID men det failar eftersom jag inte har någon kortläsare ansluten. Däremot om jag väljer att logga in med BankID
på fil så får jag bara upp:

An error occurred during a connection to eleg.handelsbanken.se.

SSL peer was unable to negotiate an acceptable set of security parameters.

(Error code: ssl_error_handshake_failure_alert)

Hälsningar
Pontus

Offline

#2 2011-11-28 22:14:55

dohlsson
Member
Registered: 2011-10-09

Re: FriBID 1.0 i Fedora 16 x64 + Handelsbanken = Fail!

Hej, jag hade samma problem som du, dock under Debian.

I mitt fall så saknade jag drivrutinen för kortläsaren, instruktioner finns på wikin: http://wiki.fribid.se/sidor/SmartCards# … ativsystem

Jag har kommit så långt att jag kunnat cachea mitt kort, men jag har fortfarande inte lyckats logga in på Handelsbanken, den säger att kortläsare saknas.

Offline

#3 2012-01-31 11:13:34

finite9
Member
Registered: 2010-10-12

Re: FriBID 1.0 i Fedora 16 x64 + Handelsbanken = Fail!

Handelsbanken fungerade inte för mig under en längre period med 0.3.0 eftersom Handelsbanken själv hade "ändrat på nåt".  Sen kom FriBid 1.0.0 och hade en fix för Handelsbankens åtgärd, och det började fungera igen.

Obs att för mig: fungerar = jag kan logga in o betala räkningar med "Sign" funktionen.  Inte fungerar = jag kan logga in, men kan inte signera nåt och därmed inte betala räkningar.

Men nu verkar det som HB har meckat igen, och även 1.0.0 har slutat fungera.  Vad är det som händer?  Är det HB som ändra på någon versionssträng eller är det något annat?

Offline

#4 2012-01-31 15:34:30

JKAbrams
Member
Registered: 2011-09-21

Re: FriBID 1.0 i Fedora 16 x64 + Handelsbanken = Fail!

@finite9: Jag loggade just in på Handelsbanken med deras kortläsare ansluten på sladd och Fribid 1.0.0, så problemet är nog inte förändrade krav på version.
Såhär ser min /~/.config/fribid/expiry ut:

[expiry]
best-before=1329980326
still-valid=true
version-to-emulate=4.15.0.14
checked-with-version=2

Får du något felmeddelande?
Fungerar http://test.bankid.com? Om inte vad ger den för felmeddelande? Se http://wiki.fribid.se/sidor/Felkoder_p% … bankid.com

Offline

Board footer

Powered by FluxBB