FriBID forum

FriBID är ett fritt program för e-legitimation med BankID.

You are not logged in.

#1 2010-09-18 12:41:56

samuellb
Administratör
Registered: 2010-02-15
Website

FriBID version 0.2.0 släppt!

Förbättringar i denna version:

• Stöd för legitimationer på kort. Kräver konfiguration, se wikin
• Uppdaterad versionssträng så att klienten känns igen som den senaste officiella versionen (4.15.0.14)
• FriBID använder OpenSSL istället för NSS nu.
• Förbättringar/städning i källkoden, m.m.

Tyvärr stämmer inte texten i Debian-paketen (det står fortfarande att det bara går att använda legitimationer på fil), men eftersom det tar lång tid för Launchpad att skapa paketen (tog 13 timmar för denna version) så släpper jag ändå denna version ändå som den är.

Offline

#2 2010-09-21 01:37:43

hno
Member
Registered: 2010-07-30

Re: FriBID version 0.2.0 släppt!

Paket för Fedora hittas på

  http://repos.fedorapeople.org/repos/hno/fribid/

Offline

#3 2010-09-25 22:19:27

magicus
Member
Registered: 2010-08-10

Re: FriBID version 0.2.0 släppt!

Trevligt med en ny version!

En fundering bara, angl. OpenSSL. Licensen för OpenSSL anses "problematisk" i samband med GPL. Det är inte uppenbart att de är inkompatibla, men det är heller inte uppenbart att de *är* kompatibla. Se t.ex. http://people.gnome.org/~markmc/openssl … e-gpl.html

Jag vet att Debian (och i praktiken därmed även Ubuntu) har en väldigt hård ståndpunkt i frågan. Så om Fribid distribueras under GPL och kräver OpenSSL, så kommer den aldrig kunna komma in i Debian. Jag har själv hållit på och fått kompilera om paket i Ubuntu (vpnc) som har skeppats utan OpenSSL-stöd, och det är ju ett himla meck.

Det är alltid lite sorgligt när fria licenser kolliderar på det här sättet. Men som jag ser det så verkar det enklast om man antingen inte använder GPL eller inte använder OpenSSL, utan t.ex. GnuTLS istället. Även om det är vansinne att politiska och inte tekniska skäl ska avgöra...

Offline

#4 2010-09-25 22:51:30

samuellb
Administratör
Registered: 2010-02-15
Website

Re: FriBID version 0.2.0 släppt!

@magicus:

FriBID är inte GPL utan har en MIT/Expact-licens. Det är vissa filer för NPAPI som är GPL, men de är trippellicensierade och kan även användas under MPL/NPL. Så jag tror inte det ska vara något problem, såvida det inte finns kompatibilitetsproblem mellan MPL/NPL och OpenSSL-licensen.

Offline

Board footer

Powered by FluxBB